Support when you need it

I was recently asked about being able to make a 'pretty' and 'modern' web interface for mission critical Domino application. It had to be perform fast, be adaptive to the device running it and work really well on the C-level execs iPads and other gadgets.

You are probably thinking, "That's a no-brainer, it's easy, just use XPages and the mobile controls and blah, blah, blah". Am I right? I thought so, because that's what I was thinking until the customer finishes their requirements list.

You know what's coming next. Right? "And all of this has to work on Domino 6.5 and don't even consider asking us to upgrade because that's too big a job and we can't do that."

As I stifle my laughter and try and compose myself into some semblance of professionalism I find myself wondering what we actually CAN do to help this situation. I start to do some research and find my good friend Stephan Wissel has already talked about how to do the Domino upgrades in the best possible way. So I'm not going to do that, but take a look at the table on the left hand side of that page. The one that shows the number of days since IBM stopped supporting that version of Domino. I checked out the links and one of them takes you to the page where IBM show you all the dates for the releases and when they stopped supporting them. It turns out that this company are running their mission critical enterprise on software that was released almost 11 years ago and has not been supported by the supplier for over 4 years now. I wonder if the board of directors in this company know about that.

All that aside, IBM Domino is a great server and very tolerant of different versions, so we can install a single Domino 9.x server into the environment to surface a pretty and modern interface for their applications.

So there is a way around this with customer's predicament, but in my opinion there is no excuse for not investing in 'mission critical' parts of your business. You would not want to secure your computers with a virus checker that has not been updated in the last 4 years. Would you?